介绍

为了安装YouCompleteMe这类插件,需要将Vim升级至比较高的版本并且启用Python3扩展。所以,这里提供的是通过源码安装Vim最新版本的过程记录。

这里使用到的Vim源代码仓库地址:https://github.com/vim/vim/

编译安装默认版本

在编译安装之前先要安装相关的工具以及依赖

% sudo apt install git make clang libpython3-dev

选择适当的目录执行克隆命令

% git clone https://github.com/vim/vim.git

克隆成功后会出现vim目录,进入该目录下的src目录

% cd vim/src

执行编译(为了加快速度可以替换执行% make -j4来并行编译)

% make

执行测试

% make test

默认安装到/usr/local目录下

% sudo make install

开启Python3扩展支持

在上述操作完成后,打开该目录下的Makefile文件,找到"CONF_OPT_PYTHON3 = --enable-python3interp"并取消注释该行,保存。

执行命令更新编译参数make reconfig

 

 

 

Scroll to Top