介绍

对于在Vim下的C/C++程序编写,如果有代码提示插件会大大提高编写效率。大型IDE用的多了,刚回归Vim的S&E比较依赖这个。正好YouCompleteMe能够满足他的相关需求。索性把安装与配置的过程记录在这里,以供下次回忆使用。

除了C/C++,YouCompleteMe支持Java、Go、C#、Objective-C、CUDA等,可以说是比较强大了。但是话说,写Java为什么要用Vim呢?IDEA貌似更好。

使用后发现这插件还支持代码跳转、引用查找、修改函数名和格式调整等操作,挺方便。

Giuhub仓库地址:https://github.com/ycm-core/YouCompleteMe

前置条件

安装最新的YouCompleteMe插件需要满足一些条件

  • Vim 8.1 以上 并且启用了Python3扩展支持(本站有过程记录,点击这里查看
  • GCC 8 以上 或者 Clang 7 以上
  • Python3.6以上编译的时候有–enable-shared选项(一般包管理器安装都带有)

对于Debian 10, 通过包管理器安装的Gcc版本为8.3.0。

然后可以通过以下命令查看编译器版本

% cc -v

对于python3的版本,使用以下命令查看

% python3 --version

对于Vim版本,使用执行以下命令查看

% vim --version

检查完以上依赖后,也执行一下以下命令确认安装相关依赖

% sudo apt install build-essential cmake vim-nox python3-dev

安装

先确认用过了Vim插件管理器安装了YouCompleteMe,推荐使用Vundle

确认安装了YouCompleteMe后,进行下面的步骤

如果你想要安装所有的功能,包括Java(JDK 8),Go、C#等代码提示功能,可以直接执行以下命令安装

% cd ~/.vim/bundle/YouCompleteMe
% python3 install.py --clangd-completer

如果你只想使用C/C++代码提示功能,则执行以下命令

% cd ~/.vim/bundle/YouCompleteMe
% python3 install.py --clangd-completer

 

Scroll to Top